
Internet Explorer Browser Clean-up 
 

Follow the steps below to determine your Internet Explorer version number and access browser 
clean-up procedures specific to your version. 

1. From Internet Explorer, click the Help menu and choose About Internet Explorer. 
2. Find the Version number and click it from the list below: 

a. Version: 8.0 
b. Version: 7.0 
c. Version: 6.0 

If you are using a browser other than Internet Explorer please review the documentation for your 
specific browser. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Internet Explorer Browser Clean-up 
 

Internet Explorer 8 
Deleting Temporary Internet files, Cookies, and History: 

Temporary Internet files, cookies, and history can slow down and cause issues with Internet 
Explorer.  These browsing history files accumulate every time Internet Explorer is used and must 
be cleaned up periodically.  Follow the steps below to clean up browsing history. 

Basic Clean-up: 
1. From Internet Explorer, click the Tools menu and click Internet Options.  
2. From the General tab, click the Delete button in the Browsing history section. 
3. Choose which files to delete by clicking the check box for each type and click the Delete 

button at the bottom of the window.  It is recommended that at least Temporary Internet 
Files, Cookies, and History be deleted. 
 
Advanced Cleanup: 

4. Click the Settings button from the Browsing History section of the Internet Options 
window. 

5. Click the radio button for “Every time I visit the webpage” in the “Check for newer 
version” section.  

6. Click the View Files button from the Temporary Internet Files section. 
 (If there are no files in the window, steps 7-9 can be skipped.) 

7. Click the Edit menu and click Select All.  
8. Click the File menu and click Delete. 
9. Click Yes to the warning pop-up message. 
10. Close the Temporary Internet Files window. 
11. Click the OK button to close the Settings window.  

 
Automatic Cleanup (optional): 

12. Click the Advanced tab from the Internet Options window and scroll down to the 
Security section at the bottom of the list. 

13. Check the box for “Empty temporary Internet Files folder when browser is closed.” 
14. Click the Ok button to close the Internet Options window. 

 

Adding Trusted Sites  

Trusted sites are web sites that are trusted to safely download or run files.  DHS web sites should 
be considered trusted sites.  Follow these steps to add trusted sites to the Trusted Sites list. 

 
1. From Internet Explorer, click the Tools menu and click Internet Options. 
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2. Click the Security tab. 
3. Click to highlight the Trusted sites icon and click the Sites button. 
4. Uncheck the box for “Require server verification (https:) for all sites in this zone.” 
5. Click the Add button to add the current site or paste the URL of a trusted site in the “Add 

this website” box and click the Add button. 
6. Click the Close button to close the Trusted Sites window. 
7. Click the Custom level button in the Security level section of the Internet Options 

window. 
8. Click the drop-down menu arrow for the “Reset to” field and Select Low from the list. 
9. Click the Reset button to apply the change. 
10. Click Yes to the warning pop-up message. 
11. Click the OK button to close the Security Settings window. 
12. Click the OK button to close the Internet Options window.  

 

Allowing pop-up messages for trusted sites: 

Internet Explorer blocks pop-up messages if that option is enabled.  Follow these steps to enable 
pop-up messages for trusted sites. 

1. From Internet Explorer, click the Tools menu, highlight Pop-up Blocker, and click Pop-
up Blocker Settings.  (If Pop-up Blocker Settings is grayed out, pop-up Blocker is not 
enabled.) 

2. Paste the URL for the trusted site in the “Address of web site to allow” box and click the 
Add button. 

3. Click the close button to close the Pop-up Blocker Settings window.  

 

Managing Toolbars and Add-ons: 

Toolbars provide easy access to features, but can interfere with Internet Explorer.  Follow these 
steps to manage toolbars. 

1. From Internet Explorer, click the View menu, highlight Toolbars, and click to enable or 
disable a Toolbar as indicated by the checkmark.  A checked Toolbar is enabled.  

Add-ons are programs that extend the capabilities of, but can interfere with Internet Explorer.  
Follow these steps to manage add-ons. 

1. From Internet Explorer, click the Tools menu and click Manage Add-ons. 
2. Highlight an Add-on in the Name column and click the disable radio button in the 

Settings section to disable it. 
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3. Click Close to close the Manage Add-ons window. 
 
Managing Toolbars and add-ons Through Windows: 
 

1. Open Start/Control Panel and double-click Add or Remove Programs 
2. Highlight the desired plug-in or toolbar and click the Remove button.  (Be careful when 

selecting because these are all of the installed programs in Windows.) 
3. Follow the prompts to remove the selection.  

 

Updating Adobe Reader: 

Some documents may not open correctly if the version of Adobe Reader is not up to date.  
Follow these steps to update Adobe Reader. 

Manual Update: 
1. Open Start/All Programs/Adobe Reader. 
2. Click the Help menu and choose Check for Updates. 
3. Close the Adobe Reader Updater window when the updates complete.  (A reboot will be 

required if an update applies) 
Automatic Updates: (optional) 

4. Click the Edit menu and choose Preferences. 
5. Click to highlight Updater at the bottom of the list. 
6. Click the radio button for “Automatically install updates” or 1 of the other options. 
7. Click OK to close the Preferences window. 
8. Close Adobe Reader. 

 

 

 

 

 

 

 

 

 



Internet Explorer Browser Clean-up 
 

Internet Explorer 7 
Deleting Temporary Internet files, Cookies, and History: 

Temporary Internet files, cookies, and history can slow down and cause issues with Internet 
Explorer.  These browsing history files accumulate every time Internet Explorer is used and must 
be cleaned up periodically.  Follow the steps below to clean up browsing history. 

Basic Clean-up: 
15. From Internet Explorer, click the Tools menu and click Internet Options.  
16. From the General tab, click the Delete button in the Browsing history section. 
17. Choose which files to delete by clicking the Delete button for each type or by clicking the 

Delete all button at the bottom of the window.  It is recommended that at least Temporary 
Internet Files, Cookies, and History be deleted.   

18. If the Delete all button was used, check the “Also delete files” box in the Delete 
Browsing History window and click the yes button.  Click the Close button when finished 
if the Delete all button was not used. 
  
Advanced Cleanup: 

19. Click the Settings button from the Browsing History section of the Internet Options 
window. 

20. Click the radio button for “Every time I visit the web page” in the check for newer 
version section. 

21. Click the View Files button from the Temporary Internet Files section. 
(If there are no files in the window, steps 8-9 can be skipped.) 

22. Click the Edit menu and click Select All.  
23. Click the File menu and click Delete. 
24. Close the Temporary Internet Files window. 
25. Click the OK button to close the Settings window.  

 
Automatic Cleanup (optional): 

26. Click the Advanced tab from the Internet Options window and scroll down to the 
Security section at the bottom of the list. 

27. Check the box for “Empty temporary Internet Files folder when browser is closed.” 
28. Click the Ok button to close the Internet Options window. 

Adding Trusted Sites  

Trusted sites are web sites that are trusted to safely download or run files.  DHS web sites should 
be considered trusted sites.  Follow these steps to add trusted sites to the Trusted Sites list. 
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13. From Internet Explorer, click the Tools menu and click Internet Options. 
14. Click the Security tab. 
15. Click to highlight the Trusted sites icon and click the Sites button. 
16. Uncheck the box for “Require server verification (https:) for all sites in this zone.” 
17. Click the Add button to add the current site or paste the URL of a trusted site in the “Add 

this website” box and click the Add button. 
18. Click the Close button to close the Trusted Sites window. 
19. Click the Custom level button in the Security level section of the Internet Options 

window. 
20. Click the drop-down menu arrow for the “Reset to” field and Select Low from the list. 
21. Click the Reset button to apply the change. 
22. Click the OK button to close the Security Settings window. 
23. Click the OK button to close the Internet Options window.  

Allowing pop-up messages for trusted sites: 

Internet Explorer blocks pop-up messages.  Follow these steps to enable pop-up messages for 
trusted sites. 

4. From Internet Explorer, click the Tools menu, highlight Pop-up Blocker, and click Pop-
up Blocker Settings.  (If Pop-up Blocker Settings is grayed out, pop-up Blocker is not 
enabled.) 

5. Paste the URL for the trusted site in the “Address of web site to allow” box and click the 
Add button. 

6. Click the close button to close the Pop-up Blocker Settings window.  

Managing Toolbars and Add-ons: 

Toolbars provide easy access to features, but can interfere with Internet Explorer.  Follow these 
steps to manage toolbars. 

1. From Internet Explorer, click the View menu, highlight Toolbars, and click to enable or 
disable a Toolbar as indicated by a checkmark.  A checked Toolbar is enabled. 

Add-ons are programs that extend the capabilities of, but can interfere with Internet Explorer.  
Follow these steps to manage add-ons. 

1. From Internet Explorer, click the Tools menu, highlight Manage Add-ons and click 
“Enable or Disable Add-ons”. 

2. Highlight an Add-on in the Name column and click the disable radio button in the 
Settings section to disable it. 

3. Click OK to close the Manage Add-ons window. 
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Managing Toolbars and add-ons Through Windows: 
 

4. Open Start/Control Panel and double-click Add or Remove Programs 
5. Highlight the desired plug-in or toolbar and click the Remove button.  (Be careful when 

selecting because these are all of the installed programs in Windows.) 
6. Follow the prompts to remove the selection.  

 

Updating Adobe Reader: 

Some documents may not open correctly if the version of Adobe Reader is not up to date.  
Follow these steps to update Adobe Reader. 

Manual Update: 
9. Open Start/All Programs/Adobe Reader. 
10. Click the Help menu and choose Check for Updates. 
11. Close the Adobe Reader Updater window when the updates complete.  (A reboot will be 

required if an update applies) 
Automatic Updates: (optional) 

12. Click the Edit menu and choose Preferences. 
13. Click to highlight Updater at the bottom of the list. 
14. Click the radio button for “Automatically install updates” or 1 of the other options. 
15. Click OK to close the Preferences window. 
16. Close Adobe Reader. 
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Internet Explorer 6 
Deleting Temporary Internet files, Cookies, and History: 

Temporary Internet files, cookies, and history can slow down and cause issues with Internet 
Explorer.  These browsing history files accumulate every time Internet Explorer is used and must 
be cleaned up periodically.  Follow the steps below to clean up browsing history. 

Basic Clean-up: 
29. From Internet Explorer, click the Tools menu and click Internet Options. 
30. From the General tab, click the Delete Cookies button in the Temporary Internet Files 

section. 
31. Also from the Temporary Internet Files section, click the Delete Files button, click the 

check box for “Delete all offline content” and click OK to close the Delete Files window. 
  
Advanced Cleanup: 

32. Click the Settings button from the Temporary Internet Files section of the Internet 
Options window. 

33. Click the “Every visit to the page” radio button for “Check for newer versions of stored 
pages.” 

34. Click the View Files button from the Temporary Internet Files section. 
(If there are no files in the window, steps 7-8 can be skipped.) 

35. Click the Edit menu and click Select All. 
36. Click the File menu and click Delete. 
37. Close the Temporary Internet Files window. 
38. Click the OK button to close the Settings window.  

 
Automatic Cleanup (optional): 

39. Click the Advanced tab from the Internet Options window and scroll down to the 
Security section at the bottom of the list. 

40. Check the box for “Empty temporary Internet Files folder when browser is closed”. 
41. Click the Ok button to close the Internet Options window. 

 

Adding Trusted Sites  

Trusted sites are web sites that are trusted to safely download or run files.  DHS web sites should 
be considered trusted sites.  Follow these steps to add trusted sites to the Trusted Sites list. 

 
24. From Internet Explorer, click the Tools menu and click Internet Options. 
25. Click the Security tab. 
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26. Click to highlight the Trusted sites icon and click the Sites button. 
27. Uncheck the box for “Require server verification (https:) for all sites in this zone.” 
28. Paste the URL of a trusted site in the “Add this website” box and click the Add button. 
29. Click the OK button to close the Trusted Sites window. 
30. Click the Custom level button in the Security level section of the Internet Options 

window. 
31. Click the drop-down menu arrow for the “Reset to” field and Select Low from the list. 
32. Click the Reset button to apply the change. 
33. Click the OK button to close the Security Settings window. 
34. Click the OK button to close the Internet Options window.  

 

Allowing pop-up messages for trusted sites: 

Internet Explorer blocks pop-up messages.  Follow these steps to enable pop-up messages for 
trusted sites. 

7. From Internet Explorer, click the Tools menu, highlight Pop-up Blocker, and click Pop-
up blocker Settings.  (If Pop-up Blocker Settings is grayed out, pop-up Blocker is not 
enabled.) 

8. Paste the URL for the trusted site in the “Address of web site to allow” box and click the 
Add button. 

9. Click the close button to close the Pop-up Blocker Settings window.  

 

Managing Toolbars and Add-ons: 

Toolbars provide easy access to features, but can interfere with Internet Explorer.  Follow these 
steps to manage toolbars. 

2. From Internet Explorer, click the View menu, highlight Toolbars, and click to enable or 
disable a Toolbar as indicated by the checkmark.  A checked Toolbar is enabled.  

Add-ons are programs that extend the capabilities of, but can interfere with Internet Explorer.  
Follow these steps to manage add-ons. 

4. From Internet Explorer, click the Tools menu and click Manage Add-ons. 
5. Highlight an Add-on in the Name column and click the disable radio button in the 

Settings section to disable it. 
6. Click OK to close the Manage Add-ons window. 

 
Managing Toolbars and add-ons Through Windows: 
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7. Open Start/Control Panel and double-click Add or Remove Programs 
8. Highlight the desired plug-in or toolbar and click the Remove button.  (Be careful when 

selecting because these are all of the installed programs.) 
9. Follow the prompts to remove the selection.  

 

Updating Adobe Reader: 

Some documents may not open correctly if the version of Adobe Reader is not up to date.  
Follow these steps to update Adobe Reader. 

Manual Update: 
17. Open Start/All Programs/Adobe Reader. 
18. Click the Help menu and choose Check for Updates. 
19. Close the Adobe Reader Updater window when the updates complete.  (A reboot will be 

required if an update applies) 
Automatic Updates: (optional) 

20. Click the Edit menu and choose Preferences. 
21. Click to highlight Updater at the bottom of the list. 
22. Click the radio button for “Automatically install updates” or 1 of the other options. 
23. Click OK to close the Preferences window. 
24. Close Adobe Reader. 


